Magento 1.4 mit PHP 5.3+ kompatibel machen

Magento Versionen 1.4 sind nicht mir PHP5.3 kompatibel, was in Fehlern endet.Das Problem ist das Magento 1.4 Funktionen benutzt die in PHP5.3 nicht mehr vorhanden sind.

Snippet Code

// In file lib/Varien/Object.php (line 484), replace
public function __toString(array $arrAttributes = array(), $valueSeparator=',')
// by
public function __invoke(array $arrAttributes = array(), $valueSeparator=',')

// In file app/code/core/Mage/Catalog/Model/Layer/Filter/Price.php (line 139), replace
$key.= $taxReq->__toString(array(), '_');
// by
$key.= $taxReq->__invoke(array(), '_');

// In file lib/Zend/Pdf/Resource/Image/Jpeg.php (line 59), replace
if (!$gd_options['JPG Support'] ) {
// by
if ( (!isset($gd_options['JPG Support']) || $gd_options['JPG Support'] != true) &&
(!isset($gd_options['JPEG Support']) || $gd_options['JPEG Support'] != true) ) {

// In the following files:
// index.php
// downloader/index.php
// downloader/Maged/Pear.php
// lib/Varien/Pear.php
// replace:
error_reporting(E_ALL | E_STRICT);
// by
error_reporting(E_ALL & E_STRICT & ~E_DEPRECATED);

Autor

Sebastian

Ich interessiere mich für eCommerce-Themen, vor allem im Zusammenhang mit dem Shopsystem Magento Commerce sowie alles rund um Web-Entwicklung und den damit verbundenen Möglichkeiten.

Ähnliche Snippets


Warning: count(): Parameter must be an array or an object that implements Countable in /homepages/22/d75420123/htdocs/mag-tutorials.de/wp-content/themes/radiate-child/content-singlesnippet.php on line 51